Web lists-archives.com

Re: Older PHP for stretch




On Fri, Oct 06, 2017 at 07:35:28AM -0500, Dave Sherohman wrote:
> Does anyone know where I might be able to find a repo with PHP 5.3 for
> stretch?  It appears that one of the web apps we depend on is
> incompatible with PHP 5.4 or newer and the official stretch php5
> packages are version 5.6.30.
> 

This is highly inadvisable, unless you are deploying within a completely
trusted environment, as PHP 5.3 has been unsupported since August 2014.
However, it did receive security backports from the Debian security team
until February 2016.

That said, if you still wish to proceed, you can download the packages
from here:

http://snapshot.debian.org/package/php5/5.3.3.1-7+squeeze29/

You may find that the binary packages install directly on stretch,
though I suspect that they may not.  You are likely to have to download
the source package and rebuild it.  There is lots of documentation out
there on the Debian Wiki on how to locally rebuild a package.

You will also want to note what additional package dependencies you are
using that are not part of the core PHP package set, as their versions
in stretch are likely to be unsuitable for such an old version of PHP.

You may also find that you have better luck deploying this on wheezy, as
the package versions will not be separated by such a large interval.
For example, the binary packages are more likely to be installable
directly on wheezy than they will be on stretch.  Wheezy will continue
to receive LTS security updates until 31st May, 2018.

Regards,

-Roberto

-- 
Roberto C. Sánchez