Web lists-archives.com

Why stretch-backports does not work for kate package?




Backports is meant to install a package using old libs.

Why does it not work for kate?

# cat /etc/apt/apt.conf
Acquire::http::Proxy "";
Acquire::ftp::Proxy "";

APT::Default-Release stretch;

$ cat /etc/apt/sources.list
deb http://httpredir.debian.org/debian/ stretch main contrib non-free
deb http://httpredir.debian.org/debian/ stretch-backports main contrib non-free
deb http://httpredir.debian.org/debian/ buster main contrib non-free
deb http://httpredir.debian.org/debian/ sid main contrib non-free
deb http://httpredir.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free

deb-src http://httpredir.debian.org/debian/ stretch main contrib non-free
deb-src http://httpredir.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://httpredir.debian.org/debian/ buster main contrib non-free
deb-src http://httpredir.debian.org/debian/ sid main contrib non-free
deb-src http://httpredir.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

$ sudo apt -t=stretch-backports install kate
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kate : Depends: ktexteditor-katepart but it is not going to be installed
        Depends: plasma-framework but it is not going to be installed
        Depends: qml-module-org-kde-kquickcontrolsaddons but it is not going to be installed
        Depends: qml-module-qtquick-layouts but it is not going to be installed
        Depends: qml-module-qtquick2 but it is not going to be installed
        Depends: kio but it is not going to be installed
        Depends: libkf5bookmarks5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5completion5 (>= 4.97.0) but it is not going to be installed
        Depends: libkf5configgui5 (>= 4.97.0) but it is not going to be installed
        Depends: libkf5configwidgets5 (>= 4.98.0) but it is not going to be installed
        Depends: libkf5crash5 (>= 5.15.0) but it is not going to be installed
        Depends: libkf5dbusaddons5 (>= 4.97.0) but it is not going to be installed
        Depends: libkf5guiaddons5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5iconthemes5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5jobwidgets5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5kiocore5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5kiofilewidgets5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5kiowidgets5 (>= 5.5.0+git20150101.0309+15.04) but it is not going to be installed
        Depends: libkf5newstuff5 (>= 5.27.0) but it is not going to be installed
        Depends: libkf5parts5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5plasma5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5service-bin but it is not going to be installed
        Depends: libkf5service5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5texteditor5 but it is not going to be installed
        Depends: libkf5textwidgets5 (>= 5.0.0) but it is not going to be installed
        Depends: libkf5wallet-bin but it is not going to be installed
        Depends: libkf5wallet5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5widgetsaddons5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5windowsystem5 (>= 4.96.0) but it is not going to be installed
        Depends: libkf5xmlgui5 (>= 4.98.0) but it is not going to be installed
        Depends: libqt5gui5 (>= 5.7.0) but it is not going to be installed
        Depends: libqt5widgets5 (>= 5.6.0~beta) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

-- 
Victor Porton - http://portonvictor.org