Web lists-archives.com

Re: virtualbox - missing packages




Am Samstag, 30. September 2017, 07:33:50 CEST schrieb Tamas Hegedus:
Hi,

maybe you need to add this entry in sources.list:

deb http://download.virtualbox.org/virtualbox/debian stretch contrib

See this doku:

https://wiki.debian.org/VirtualBox#Debian_9_.22Stretch.22

Hope this helps.
Good luck!

Best

Hans
> Hi,
> 
> A few weeks ago I could install virtualbox on stretch w/o any problem.
> Now I try to install on a different computer and have the broken
> packages error shown below.
> 
> At the same time I have installed:
> i   libssl1.0.2                                               - Secure
> Sockets Layer toolkit - shared libraries
> i   libssl1.1                                                 - Secure
> Sockets Layer toolkit - shared libraries
> 
> I also installed vpx-tools
> 
> I also have
> 
> i   linux-image-amd64                                         - Linux
> for 64-bit PCs (meta-package)
> 
> What can I do?
> Thanks a lot for your help in advance.
> 
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Note, selecting 'virtualbox-5.1' instead of 'virtualbox'
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>   virtualbox-5.1 : Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
> Depends: libvpx3 (>= 1.5.0) but it is not installable Recommends:
> linux-image but it is not installable E: Unable to correct problems, you
> have held broken packages.