Web lists-archives.com

Re: Mismatch of wxglade and wxwidgets






On 12/9/17 5:27 pm, Michael Lange wrote:
On Tue, 12 Sep 2017 15:02:35 +1000
"Brendan Simon (eTRIX)" <brendan.simon@xxxxxxxxxxxx> wrote:

I'm running Debian 8 Jessie.

There seems to be a mismatch between wxglade (`python-wxglade`) and
wxwidgets (`python-wxgtk3.0`)

If I install wxglade and run it, I can choose to generate code for wx
2.6 or 2.8 compatibility.  However the wx widgets that are installed use
wx 3.0.

It seems to me that wxglade needs to be updated in Jessie, to be
compatible with the installed wxwidgets.

According to the webpage at sourceforge, wxglade v0.7 added wx 3.0
compatibility and removed wx 2.6.

    http://wxglade.sourceforge.net/

v0.7.2 is latest release according to the sourceforge page, however the
BitBucket repository states that it is out of date and to use the latest
in the repository (a new maintainer).

    https://bitbucket.org/wxglade/wxglade

### How do I request getting `python-wxglade` updated to at least
version 0.7.2 ??
you could use reportbug to file a bug against python-wxglade. I doubt
however that this will be fixed for Jessie, but of course you could try.
Have you checked if the bug still persists with Stretch?

Looks ok in Stretch (wxglade is at version `0.7.2-2`)

https://packages.debian.org/stretch/wxglade

I will report a bug and see what happens.  It's not critical for me as I'm actually using the latest from the source repo.  Maybe backports will update wxglade ?

Thanks, Brendan.