Web lists-archives.com

Install Debian 9.1 stretch on Pentium II system: pata_hpt3x2n required?




Hello

I am attempting to install Debian 9.1 stretch on an old Pentium II system.

Setup --

cpu Pentium II 400 MHz
ram 512 MB
video card ATI RAGE IIC AGP
hdd #1 6.8 GB Fujitsu (with Windows installed, also a 1GB Linux swap partition)
hdd #2 80 GB Seagate, attached to Highpoint 133SB Rocket Raid (PCI) card

Install process goes well until the stage of searching for disks. Then the first disk is detected fine, but 2nd doesn't show up.

If I pause the installation sequence at disk detection, driver pata_hpt37x is shown by lsmod. lspci shows the Highpoint card as "RAID bus controller HighPoint Technologies, Inc. HPT302/302N (rev 02)".

As some background, Knoppix 7.2.0 installs okay on the Seagate drive but I seem to have broken it by upgrading some packages (and removing libreoffice). On boot, Knoppix complains that graphics cannot be initialised, I think because package xserver-xorg-video-ati has been unpacked but not installed (i.e., on the Knoppix hdd installation). 

The aim is to see if this old machine can take on a new life as a router. Traffic rates through it are adequate for current needs. If Debian install can be completed, I will switch to LXDE for the desktop (quite lightweight as I understand).

If Debian can be installed Knoppix will be replaced but the old Windows install on hdd #1 will be retained.

After a little research, I believe a driver pata_hpt3x2n might be required? 

All help gratefully received.

David Max