Web lists-archives.com

Re: lilypond workaround against lilypond-removal




On Thu 31 Aug 2017 at 20:43:34 (+0200), rrbuerger@xxxxxxxxxx wrote:
> My lilypond - experience and workaround-solution with debian stretch:
> 
> I updated 2 PCs (precisely a pc and a laptop) at the beginning of July
> 2017 from a zero-errors-running Jessie to a (censored by vice squad
> ;-) ) Stretch.
> 
> One of the knockouts was: I had overlooked, that lilypond is removed
> in Stretch "because" an unsolved Guile-"Problem". Nebbisch?!
> 
> So I sat in the trap as a professional musician - had new systems, but
> they worked not for me into the right direction.
> 
> But, I can't solve my professional tasks with 0.A.D., I need
> lilypond. ;-)
> 
> At fist, I believed, I had to wait for a solution of this
> Guile-Problem. :-(
> 
> Then I thought: This can take years, or decades - because I'm waiting
> already since 20 years very unsuccessful of a userfriendly
> out-of-the-box-and-without-mammut-latencies-running sound- and
> understandable printing-solution for linux too (I'm 59 now) - maybe,
> the solutions are written somedeay only on my tomb-bow posthumous, or
> on the tombs of my grand-grand-children ...
> 
> Short: I had a very need for a workaround, and wrote for this to the
> lilypond-project itself.
> 
> An easy and short correspondence came out and then came the right
> question from Trevor Daniels:
> 
> " Can you not download one of the binaries from here?
> 
> http://lilypond.org/development.html "

This link takes you to the 2.19 development branch. You
presumably used http://lilypond.org/download.html for
the 2.18 stable branch.

> A try and: BINGO!
> 
> 
> So, this was my way:
> 
> - I'm using debian stretch, very new installation on an old quad AMD
>   hardware

Quad, old?

> - downloaded lilypond from http://lilypond.org/unix.html
> (in my case: the link of "GNU/Linux 64: LilyPond 2.18.2-1 64bit
> Systems. " )
> 
> - copied the downloaded file (named: "lilypond-2.18.2-1.linux-64.sh"
>   into /usr/local/bin by:
> 
> cp ./lilypond-2.18.2-1.linux-64.sh /usr/local/bin
> 
> - then I set the x (for "make it running" ;-)  ) by:
> 
> chmod +x lilypond-2.18.2-1.linux-64.sh
> 
> - then I started the shell-script by
> 
> ./lilypond-2.18.2-1.linux-64.sh
> 
> - and the whole lilypond was installed in a moment
> 
> - so i started frescobaldi and frescobaldi found the lilypond now
>   without further work - and: Is working now again!

I use a slightly different way which enables having several LP
versions available. I download to my non-Debian archive, then

$ cd ~
$ bash …/lilypond-xxxnewxxx.linux-x86.sh --prefix lilypond-xxxnewxxx

If this is the version I want to run by default, I copy the links in
~/lilypond-xxxnewxxx/bin/ and ~/lilypond-xxxnewxxx/bin/lilypond
into ~/bin/, overwriting the old ones there.

Uninstalling old versions is just a matter of

$ bash ~/lilypond-xxxoldxxx/bin/uninstall-lilypond

If you're a Frescobaldi user, it just remains to tell it which
version you want it to use (through its menus).

> - I have a running lilypond under Debian Stretch(! wow! ;-)  ) this way
>   now again
> 
> 
>   - maybe, it helps other Debian-Stretch-Tricked too.
> 
> 
> Ofcourse it would be better, if the Debian-Project would find a way to
> workaround the guile-"problem" and reintegrate immedially lilypond
> into the Stretch-repositories again (not all debian-users are such
> "creative IT-professionals" like me ;-) LOOOL (seriously: a big thanks
> to Trevor!! - some thousand of exclamation marks!) , maybe, my fellows
> in misery believe the debian statements really (like me at the
> beginning ;-) ) and without further questions ;-) , so the damage for
> them by such destructive "solutions" like simply "removing instead
> solving" (is this the new Debian-Way???)  is predictable immense
> (Again: Is this todays "solution", simply to remove lilypond (what
> ever, p.e. oss, from there, a really way, if we fall back into old,
> not-running-times again this way - and this, after lilypond was a very
> good, responsible and professional running part of the debian project
> already, over years in the past?? Its a very serious PR-damage too for
> the Debian-Maintainers
> - not only in my own eyes - who needs this?? Whom's use is this?  ...
> and all this in times of whole "virtual OS'ses"?? Or is it simple a
> hidden, silent sabotage of the Debian AND lilypond project???
> 
> Anyway.
> 
> It's not the best reputation for the Debian-Projekt in my eyes and at
> moment, if problems are "solved" by removing and on the (tricky
> or unprofessional, this is here the question?) way of too shorttimed
> alarms!

IIRC the LilyPond people were still debating what to do about the
Guile 1→2 problem in January; whether to fork 1.8 for LP, whether
to statically or dynamically link it, whether to skip 2.0 (which
seems to have major problems that never get fixed) and go straight
to the newly released 2.2, etc. It will be interesting to see if
this decision has been made by the time LP 2.20 is released.

If you really need LP 2.18, then there's the backports path, as
mentioned by Thomas, or sticking with wheezy. But most serious users
of LP are using the 2.19 branch which has a lot of improvements
as outlined in http://lilypond.org/doc/v2.19/Documentation/changes.pdf

Cheers,
David.