Web lists-archives.com

Error! Bad dkms.conf file after apt-get upgrade




Hello all,

After running 'apt-get install upgrade' the system reported the data below.

How can I overcome this issue? 

Is it just a matter of loading a proper dkms.conf file, perhaps from another Stretch installation, or is there an official dkms.conf file that I can download somewhere, or is it a matter of removing the dkms package and reinstalling it, or repairing/reinstalling it?

I am grateful for any assistance/insight into this issue you are able to provide.  ADVthanksANCE.

Best regards,
Larry

===============================================================================
Fri Aug 11 08:26:01 PDT 2017

Setting up linux-image-4.9.0-3-amd64 (4.9.30-2+deb9u3) ...
Progress: [ 89%]
/etc/kernel/postinst.d/dkms:
/usr/sbin/dkms: line 485: .: /var/lib/dkms/rtl8814/4.3.21/source/dkms.conf: cannot execute binary file
dkms.conf: Error! No 'DEST_MODULE_LOCATION' directive specified.
dkms.conf: Error! No 'PACKAGE_NAME' directive specified.
dkms.conf: Error! No 'PACKAGE_VERSION' directive specified.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: /etc/kernel/postinst.d/dkms exited with return code 8
dpkg: error processing package linux-image-4.9.0-3-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for hicolor-icon-theme (0.15-1) ...
Progress: [ 90%]
Setting up git (1:2.11.0-3+deb9u1) ...
Progress: [ 92%]
Progress: [ 93%]
Setting up linux-headers-4.9.0-3-amd64 (4.9.30-2+deb9u3) ...
Progress: [ 95%]
/etc/kernel/header_postinst.d/dkms:
/usr/sbin/dkms: line 485: .: /var/lib/dkms/rtl8814/4.3.21/source/dkms.conf: cannot execute binary file
dkms.conf: Error! No 'DEST_MODULE_LOCATION' directive specified.
dkms.conf: Error! No 'PACKAGE_NAME' directive specified.
dkms.conf: Error! No 'PACKAGE_VERSION' directive specified.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 8
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-4.9.0-3-amd64.postinst line 11.
dpkg: error processing package linux-headers-4.9.0-3-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 linux-image-4.9.0-3-amd64
 linux-headers-4.9.0-3-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)


Upgrade Debian system before continuing (apt-get install dist-upgrade) [Y/n]? ^[
Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up linux-headers-4.9.0-3-amd64 (4.9.30-2+deb9u3) ...
Progress: [  0%]
/etc/kernel/header_postinst.d/dkms:
/usr/sbin/dkms: line 485: .: /var/lib/dkms/rtl8814/4.3.21/source/dkms.conf: cannot execute binary file
dkms.conf: Error! No 'DEST_MODULE_LOCATION' directive specified.
dkms.conf: Error! No 'PACKAGE_NAME' directive specified.
dkms.conf: Error! No 'PACKAGE_VERSION' directive specified.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 8
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-4.9.0-3-amd64.postinst line 11.
dpkg: error processing package linux-headers-4.9.0-3-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up linux-image-4.9.0-3-amd64 (4.9.30-2+deb9u3) ...
/etc/kernel/postinst.d/dkms:
/usr/sbin/dkms: line 485: .: /var/lib/dkms/rtl8814/4.3.21/source/dkms.conf: cannot execute binary file
dkms.conf: Error! No 'DEST_MODULE_LOCATION' directive specified.
dkms.conf: Error! No 'PACKAGE_NAME' directive specified.
dkms.conf: Error! No 'PACKAGE_VERSION' directive specified.
Error! Bad conf file.
File:
does not represent a valid dkms.conf file.
run-parts: /etc/kernel/postinst.d/dkms exited with return code 8
dpkg: error processing package linux-image-4.9.0-3-amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 linux-headers-4.9.0-3-amd64
 linux-image-4.9.0-3-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
===============================================================================