Web lists-archives.com

Re: debian 9.1 dpkg error when installing xemacs and erlang




On Thu, Aug 10, 2017 at 06:37:41PM +0200, Rémy Noulin wrote:
> On a freshly installed debian 9.1, apt-get fails to install xemacs due to
> some compilation related to erlang, here is the interesting part of log:
> 
> Compiling /usr/share/xemacs21/site-lisp/erlang/erldoc.el...
> While compiling toplevel forms in file
> /usr/share/xemacs21/site-lisp/erlang/erldoc.el:
>   !! File error (("Cannot open load file" "cl-lib"))
> >>Error occurred processing erldoc.el: Cannot open load file: cl-lib
> 
> Compiling /usr/share/xemacs21/site-lisp/erlang/path.el...
> Wrote /usr/share/xemacs21/site-lisp/erlang/path.elc
> Done
> ERROR: install script from erlang-mode package failed
> dpkg: error processing package xemacs21-mule (--configure):
>  subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of xemacs21:
>  xemacs21 depends on xemacs21-mule (>= 21.4.24-4) | xemacs21-mule-canna-wnn
> (>= 21.4.24-4) | xemacs21-nomule (>= 21.4.24-4); however:
>   Package xemacs21-mule is not configured yet.
>   Package xemacs21-mule-canna-wnn is not installed.
>   Package xemacs21-nomule is not installed.
> 
> dpkg: error processing package xemacs21 (--configure):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  xemacs21-mule
>  xemacs21
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 

OK so it looks like it can't complete the build because the cl-lib 
component it needs is missing. 

A good guess would be that this file is in another package that isn't 
installed, that the package for xemacs assumes will be installed but 
which isn't in its dependencies. That would arguably be a bug, but even 
if it is a bug that doesn't help you much, you still need to navigate 
out of the situation you are in.

So here's how to determine where that cl-lib component is:

1. Install apt-file if you don't have it already.
2. sudo apt-file update
<you'll get a bunch of irrelevant output and it will take a minute or two>
3. apt-file search cl-lib

On my system the 3rd command produces:

aolserver4-doc: /usr/share/doc/aolserver4-doc/html/devel/tcl/tcl-libraries.html
emacs24-common: /usr/share/emacs/24.5/lisp/emacs-lisp/cl-lib.elc
emacs24-el: /usr/share/emacs/24.5/lisp/emacs-lisp/cl-lib.el.gz
emacs25-common: /usr/share/emacs/25.1/lisp/emacs-lisp/cl-lib.elc
emacs25-el: /usr/share/emacs/25.1/lisp/emacs-lisp/cl-lib.el.gz
maxima-src: /usr/share/maxima/5.38.1/src/numerical/f2cl-lib.lisp

aolserver4-doc and maxima-src are probably red herrings. You need one or 
more of emacs2{4,5}-{common,el} installed. I _think_ you are going to 
want to go either with the -24 or -25 series, not both, and if you held 
a gun to my head I would say it's probably the -el package rather than 
the -common package that you need, but that could easily be wrong. See 
which ones are not already installed on your system -- something that's 
already there isn't the missing package! :)

Hope that helps.

Mark