Web lists-archives.com

cups: Backend /usr/lib/cups/backend/usb does not exist! [solved]




Hi everybody,

it took me quite a while to figure this out so I thought I post this
here for someone else in need to find this.

I wanted to reinstall my printer Brother HL-3040CN after I upgraded to
stretch. That didn't work at first. The installer failed with "Backend
/usr/lib/cups/backend/usb does not exist!". ldadmin gave 'Bad device-uri
scheme "usb"'.

The solution was easy, if I had known what to do: copy
/usr/lib/cups/backend-available/usb to /usr/lib/cups/backend/. Doi!

Maybe this will help someone in the future.

Simon