Web lists-archives.com

Re: apt or apt-get equivalent of 'aptitude --show-why upgrade'




Christoph Groth composed on 2017-08-02 17:44 (UTC+0200):

> I'm running Debian testing and would like to upgrade from 
> "oldtesting" (jessie) to current testing.  I noticed that 'apt 
> upgrade' as well as 'apt-get upgrade' want to install the package 
> 'pulsaudio' which I've been avoiding successfully so far.

> I could of course uninstall pulseaudio after the upgrade, but I 
> wonder whether a more elegant solution does not exist.

I wonder if this is a consequence of Firefox's recently added pulseaudio
requirement for providing sound?

I avoid installing individual packages, rather than via pinning, in this manner:

	apt-mark hold pulseaudio

If pulseaudio is simply recommended, block recommends globally via /etc/apt:

	APT::Install-Recommends "false";
-- 
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/