Web lists-archives.com

Re: Sound problems (mpd, mpv mainly)




On Mon, 17 Apr 2017, kamaraju kusumanchi wrote:
> On Sat, Apr 8, 2017 at 7:09 AM, Pierre Frenkiel
> <pierre.frenkiel@xxxxxxxxx> wrote:
> >   Nevertheless, I don't see why this package is not
> >   upgraded in Jessie: it just gives a list, and have then no dependency
> >   problem.
> 
> Packages in Debian Stable are upgraded only when it fixes a security
> related issue. I agree that the change is very small in this case. But

This is incorrect.  Usability issues, as long as they are important
enough, can also be fixed through stable updates, especially when it is
the case of a leaf package, that has less risk of causing regressions on
other packages.

What *does* matter is that the change can be fully understood, and that
the change *is* heavily tested so there are no regressions.

> it does not qualify for an update.

It could, as long as it is very heavily tested.  You will only know if
you do the aforementioned testing, and write a *proper* request (through
reportbug) for the stable release managers asking about it.  Note that
doing this properly is important.  No shortcuts.  No halfbaked reports
missing information.

If it is _not_ worth the trouble, then you know it is not important
enough to deserve a stable update :-)

-- 
  Henrique Holschuh