Web lists-archives.com

Re: [Stable] Trouble with openvpn




Leandro Noferini <lnoferin@xxxxxxxxxxxxxxx> writes:

> If I start openvpn with systemd (with "service openvpn start" command)
> or with the gnome panel command the route configured is only for the
> server and not the subnet for the vpn. This is the routing table usgin
> these commands:
>
> default via 10.150.29.1 dev eth0  proto static  metric 1024 
> 10.150.29.0/24 dev eth0  proto kernel  scope link  src 10.150.29.101 
> 169.254.0.0/16 dev eth0  scope link  metric 1000 
> 192.168.73.1 dev tun0  proto kernel  scope link  src 192.168.73.5 
> (192.168.73.X is the subnet for the vpn).
>
> But, if I start openvpn directly with the command
>
> openvpn --config server.conf
>
> the resulting route is correct:
>
> default via 10.150.29.1 dev eth0  proto static  metric 1024 
> 10.150.29.0/24 dev eth0  proto kernel  scope link  src 10.150.29.101 
> 169.254.0.0/16 dev eth0  scope link  metric 1000 
> 192.168.73.0/24 via 192.168.73.1 dev tun0 
> 192.168.73.1 dev tun0  proto kernel  scope link  src 192.168.73.5 
> With the same configuration, changing only the authentication, it works
> perfectly on a sid with every command I use.

Paul Wise <pabs@xxxxxxxxxx> writes:

> Try looking at the openvpn logs or systemd journal while you start
> openvpn via the three different methods. If you compare the logs, you
> might get a hint about what is happening.

I made some tries with different configurations and I found it works
normally removing the lines "user" and "groups" from the configuration
file.

Is it right/normal?

-- 
leandro
1A0B 125B 2E4D 2DAE 4E26  4551 88FB BBCC 7A29 640B
https://bbs.cybervalley.org/ChiaveLeandro/gpg.html
http://6xukrlqedfabdjrb.onion
La caratteritica principale dei miracoli è che non accadono

Attachment: signature.asc
Description: PGP signature