Web lists-archives.com

Matrox G550 - MGA X server fails




I am unable to start X using a Matrox Millennium G550 PCIe card.

This is what I think is the relevant part of the log for the session:

#011compiled for 1.19.2, module version = 0.1.0
#011ABI class: X.Org Video Driver, version 23.0
(--) MGA(0): Chipset: "mgag550"
xf86TokenToOptinfo: table is NULL
xf86TokenToOptinfo: table is NULL
(==) MGA(0): Using HW cursor
(--) MGA(0): Linear framebuffer at 0xF0000000
(--) MGA(0): MMIO registers at 0xF7020000
(--) MGA(0): Pseudo-DMA transfer window at 0xF6800000
(EE) MGA(0): Unable to map Framebuffer F0000000 2000000.  Permission
denied (13)
(II) MGA(0): Creating default Display subsection in Screen section
#011"Default Screen Section" for depth/fbbpp 24/32
(==) MGA(0): Depth 24, (--) framebuffer bpp 32
(==) MGA(0): RGB weight 888
(==) MGA(0): Using AGP 1x mode
(==) MGA(0): Using XAA acceleration
(WW) MGA(0): Could not retrieve video BIOS!
(EE) MGA(0): Unable to detect video RAM.
(II) UnloadModule: "mga"

The full log is attached.

Can anyone indicate what the problem is, please?

Packages:
15:40:59 phoenix systemd[1]: Started User Manager for UID 118.
(--) Log file renamed from "/var/lib/gdm3/.local/share/xorg/Xorg.pid-9327.log" to "/var/lib/gdm3/.local/share/xorg/Xorg.0.log"
X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
Current Operating System: Linux phoenix 4.9.0-2-amd64 #1 SMP Debian 4.9.13-1 (2017-02-27) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-2-amd64 root=UUID=72b9d4db-4d0e-466f-b90e-0a1a72dffcba ro quiet
Build Date: 03 March 2017  03:14:41PM
xorg-server 2:1.19.2-1 (https://www.debian.org/support)
Current version of pixman: 0.34.0
#011Before reporting problems, check http://wiki.x.org
#011to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
#011(++) from command line, (!!) notice, (II) informational,
#011(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/lib/gdm3/.local/share/xorg/Xorg.0.log", Time: Mon Mar 20 15:40:59 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(==) No screen section available. Using defaults.
(**) |-->Screen "Default Screen Section" (0)
(**) |   |-->Monitor "<default monitor>"
(==) No monitor specified for screen "Default Screen Section".
#011Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Automatically adding GPU devices
(==) Max clients allowed: 256, resource mask: 0x1fffff
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
#011Entry deleted from font path.
(==) FontPath set to:
#011/usr/share/fonts/X11/misc,
#011/usr/share/fonts/X11/100dpi/:unscaled,
#011/usr/share/fonts/X11/75dpi/:unscaled,
#011/usr/share/fonts/X11/Type1,
#011/usr/share/fonts/X11/100dpi,
#011/usr/share/fonts/X11/75dpi,
#011built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
#011If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x557672802e00
(II) Module ABI versions:
#011X.Org ANSI C Emulation: 0.4
#011X.Org Video Driver: 23.0
#011X.Org XInput driver : 24.1
#011X.Org Server Extension : 10.0
(++) using VT number 1
(II) systemd-logind: took control of session /org/freedesktop/login1/session/c313
(II) xfree86: Adding drm device (/dev/dri/card0)
(II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 12 paused 0
(--) PCI: (0:0:2:0) 8086:0412:1458:d000 rev 6, Mem @ 0xf7400000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
(--) PCI:*(0:2:0:0) 102b:2527:102b:22c0 rev 1, Mem @ 0xf0000000/33554432, 0xf7020000/16384, 0xf6800000/8388608, BIOS @ 0x????????/131072
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
#011compiled for 1.19.2, module version = 1.0.0
#011ABI class: X.Org Server Extension, version 10.0
(==) Matched mga as autoconfigured driver 0
(==) Matched modesetting as autoconfigured driver 1
(==) Matched fbdev as autoconfigured driver 2
(==) Matched vesa as autoconfigured driver 3
(==) Assigned the driver to the xf86ConfigLayout
(II) LoadModule: "mga"
(II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
(II) Module mga: vendor="X.Org Foundation"
#011compiled for 1.19.1, module version = 1.6.5
#011Module class: X.Org Video Driver
#011ABI class: X.Org Video Driver, version 23.0
(II) LoadModule: "modesetting"
(II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
(II) Module modesetting: vendor="X.Org Foundation"
#011compiled for 1.19.2, module version = 1.19.2
#011Module class: X.Org Video Driver
#011ABI class: X.Org Video Driver, version 23.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
#011compiled for 1.19.0, module version = 0.4.4
#011Module class: X.Org Video Driver
#011ABI class: X.Org Video Driver, version 23.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
#011compiled for 1.19.0, module version = 2.3.4
#011Module class: X.Org Video Driver
#011ABI class: X.Org Video Driver, version 23.0
(II) MGA: driver for Matrox chipsets: mga2064w, mga1064sg, mga2164w,
#011mga2164w AGP, mgag100, mgag100 PCI, mgag200, mgag200 PCI,
#011mgag200 SE A PCI, mgag200 SE B PCI, mgag200 EV Maxim,
#011mgag200 ER SH7757, mgag200 eW Nuvoton, mgag200 eW3 Nuvoton,
#011mgag200eH, mgag400, mgag550
(II) modesetting: Driver for Modesetting Kernel Drivers: kms
(II) FBDEV: driver for framebuffer: fbdev
(II) VESA: driver for VESA chipsets: vesa
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(G0): using drv /dev/dri/card0
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
#011compiled for 1.19.2, module version = 0.0.2
#011ABI class: X.Org Video Driver, version 23.0
(EE) open /dev/fb0: Permission denied
(WW) Falling back to old probe method for vesa
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/lib/xorg/modules/libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
#011compiled for 1.19.2, module version = 0.1.0
#011ABI class: X.Org Video Driver, version 23.0
(--) MGA(0): Chipset: "mgag550"
xf86TokenToOptinfo: table is NULL
xf86TokenToOptinfo: table is NULL
(==) MGA(0): Using HW cursor
(--) MGA(0): Linear framebuffer at 0xF0000000
(--) MGA(0): MMIO registers at 0xF7020000
(--) MGA(0): Pseudo-DMA transfer window at 0xF6800000
(EE) MGA(0): Unable to map Framebuffer F0000000 2000000.  Permission denied (13)
(II) MGA(0): Creating default Display subsection in Screen section
#011"Default Screen Section" for depth/fbbpp 24/32
(==) MGA(0): Depth 24, (--) framebuffer bpp 32
(==) MGA(0): RGB weight 888
(==) MGA(0): Using AGP 1x mode
(==) MGA(0): Using XAA acceleration
(WW) MGA(0): Could not retrieve video BIOS!
(EE) MGA(0): Unable to detect video RAM.
(II) UnloadModule: "mga"
(II) UnloadSubModule: "vgahw"
(II) Unloading vgahw
(==) modeset(G0): Depth 24, (==) framebuffer bpp 32
(==) modeset(G0): RGB weight 888
(==) modeset(G0): Default visual is TrueColor
(II) Loading sub module "glamoregl"
(II) LoadModule: "glamoregl"
(II) Loading /usr/lib/xorg/modules/libglamoregl.so
(II) Module glamoregl: vendor="X.Org Foundation"
#011compiled for 1.19.2, module version = 1.0.0
#011ABI class: X.Org ANSI C Emulation, version 0.4
(II) glamor: OpenGL accelerated X.org driver based.
(II) glamor: EGL version 1.4 (DRI2):
(II) modeset(G0): glamor initialized
(II) modeset(G0): Output VGA-1-1 has no monitor section
(II) modeset(G0): Output HDMI-1-1 has no monitor section
(II) modeset(G0): EDID for output VGA-1-1
(II) modeset(G0): EDID for output HDMI-1-1
(==) modeset(G0): Using gamma correction (1.0, 1.0, 1.0)
(==) modeset(G0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
#011compiled for 1.19.2, module version = 1.0.0
#011ABI class: X.Org ANSI C Emulation, version 0.4
(EE) Screen(s) found, but none have a usable configuration.
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
(EE) Server terminated with error (1). Closing log file.
Unable to run X server