Web lists-archives.com

Re: Which kernel version (and sub-version) do I have?




On Mon, Mar 13, 2017 at 10:18:03PM +0100, Georg Stillfried wrote:
> can someone please help me find out which kernel version (and 
> sub-version) I have?

uname -a

> $ uname -v
> #1 SMP Debian 3.16.7-ckt25-2+deb8u3 (2016-07-02)
> 
> $ uname -r
> 3.16.0-4-686-pae

Or that.  It's the same as uname -a, just in pieces.

> So is the kernel version of my system 3.16.7, 3.16.0 or 3.16.63?

Yes.  Two of the above.

You are running Debian kernel 3.16.7-ckt25-2+deb8u3 which is compatible
with the kernel ABI used in Debian kernel *package* 3.16.0-4-686-pae.

> (Backgroud: I wanted to find out whether the Dirty COW bug was fixed in 
> my system.

No, not yet.

> According to
> https://en.wikipedia.org/wiki/Dirty_COW#Remedies_and_recourse, it is 
> fixed from version 3.16.36-1+deb8u2 onwards.)

You are running a kernel that is older than this.  If you have
installed a newer kernel, you have not yet rebooted into it.

https://security-tracker.debian.org/tracker/CVE-2016-5195 confirms
that you want 3.16.36-1+deb8u2.  (Best not to rely 100% on wikipedia
without verification.)