Web lists-archives.com

Re: `Filter failed' no print error message




Brian <ad44@xxxxxxxxxxxxxxx> writes:

> On Sat 11 Mar 2017 at 21:06:23 +0000, Rodolfo Medina wrote:
>
>> Brian <ad44@xxxxxxxxxxxxxxx> writes:
>> 
>> > On Tue 07 Mar 2017 at 15:41:54 +0000, Rodolfo Medina wrote:
>> >
>> >> 
>> >> Thanks, `cups' alone was enough.  Now the printer seems to be configured.
>> >> But it does not print, and, when I get into `jobs', I see they are
>> >> stopped with "Filter failed" claim.  What can I do?  Please help.
>> >> Thanks.
>> >
>> > Read the wiki and find out how to activate debug logging. Produce an
>> > error_log and examine it for the filters which are run and which one
>> > failed. Tell us about all the filters.
>> >
>> > Also, post your printer make and model and the output of 'lpstat -t'.
>> 
>> 
>> I noticed that CUPS does not really provide the PPD file I'm adding.  In
>> fact, there in the managing section, `Modify Printer', where it says `Or
>> Provide a PPD File', I select the file: ML-191xspl2.ppd, which is in my home
>> directory, then click on `Modify Printer' and it seems all right; but then,
>> when I get into it again, the file is no more there, and there is `No file
>> selected' instead.  Maybe this is related to my `Filter failed' problem...?
>
> There are seven instructions in the advice given. You haven't provided a
> response to any of them. If there is a problem with following what is
> required, please ask.

As the wiki suggests, I did:

 # cupsctl --debug-logging

.  Then I did:

$ lpstat -t
scheduler is running
system default destination: Samsung_ML-191x_252x_Series
device for Samsung_ML-191x_252x_Series: usb://Samsung/ML-191x%20252x%20Series?serial=Z2L9BABZ700571F.
Samsung_ML-191x_252x_Series accepting requests since Sun 12 Mar 2017 07:44:58 GMT
printer Samsung_ML-191x_252x_Series is idle.  enabled since Sun 12 Mar 2017 07:44:58 GMT
        Sending data to printer.
Samsung_ML-191x_252x_Series-16 rodolfo         457728   Sat 11 Mar 2017 19:56:36 GMT
Samsung_ML-191x_252x_Series-17 unknown           1024   Sat 11 Mar 2017 20:09:12 GMT
Samsung_ML-191x_252x_Series-18 unknown         457728   Sat 11 Mar 2017 20:20:18 GMT
Samsung_ML-191x_252x_Series-19 rodolfo         457728   Sun 12 Mar 2017 07:44:49 GMT


The file /var/log/cups/error_log is very long.  I noticed in it the following
lines:

D [07/Mar/2017:14:35:23 +0000] [Job 1] Started filter /usr/lib/cups/filter/pdftopdf (PID 4741)
D [07/Mar/2017:14:35:23 +0000] [Job 1] Started filter /usr/lib/cups/filter/pdftops (PID 4742)
D [07/Mar/2017:14:35:23 +0000] [Job 1] Started filter /usr/lib/cups/filter/rastertosamsungspl (PID 4743)
D [07/Mar/2017:14:35:23 +0000] [Job 1] Started backend /usr/lib/cups/backend/usb (PID 4744)
D [07/Mar/2017:14:35:23 +0000] [Job 1] pdftops - copying to temp print file \"/var/spool/cups/tmp/0128658cb23ec\"
D [07/Mar/2017:14:35:23 +0000] [Job 1] execv failed: No such file or directory
D [07/Mar/2017:14:35:23 +0000] [Job 1] PID 4743 (/usr/lib/cups/filter/rastertosamsungspl) stopped with status 102 (No such file or directory)
D [07/Mar/2017:14:35:23 +0000] [Job 1] Hint: Try setting the LogLevel to "debug" to find out more.


Don't know what to do now, please help...

Thanks,

Rodolfo