Web lists-archives.com

USB Token with power problem.




Hi, Guys!

I am trying to use my USB Token on Debian Jessie, but it turns on the light, and in three seconds, it turns off. So, the USB Token stops working.

I found in the Internet that it can be a power problem. They recommended to run the following command:

echo 'on' | tee /sys/bus/usb/devices/usb2/power/level

It changes the value on that file, but the behavior remains the same.

In this way, I ask for help. My Debian informations are below.

uname -na
Linux ncc1701 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1 (2016-12-30) x86_64 GNU/Linux

lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 007: ID 0bda:5754 Realtek Semiconductor Corp. 
Bus 002 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 002 Device 005: ID 04f3:2013 Elan Microelectronics Corp. 
Bus 002 Device 004: ID 8087:0a2a Intel Corp. 
Bus 002 Device 011: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 002 Device 015: ID 1059:0017 Giesecke & Devrient GmbH (that is my USB Token)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/11p, 480M
    |__ Port 1: Dev 15, If 0, Class=Chip/SmartCard, Driver=, 12M
    |__ Port 3: Dev 11, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 3: Dev 11, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 5: Dev 4, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 5: Dev 4, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 6: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 7: Dev 6, If 0, Class=Vendor Specific Class, Driver=rtsx_usb, 480M
    |__ Port 8: Dev 7, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 8: Dev 7, If 1, Class=Video, Driver=uvcvideo, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M

dmesg | grep 1059
[    1.612648] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1002.610934] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1053.523985] usb 2-2: New USB device found, idVendor=1059, idProduct=0017
[ 1090.249734] usb 2-2: New USB device found, idVendor=1059, idProduct=0017
[ 1762.296078] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1788.281211] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1794.658211] usb 2-2: New USB device found, idVendor=1059, idProduct=0017
[ 1997.061059] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 7282.511744] usb 2-1: New USB device found, idVendor=1059, idProduct=0017

dmesg | grep 0017
[    0.744411] Freeing unused kernel memory: 216K (ffff8800017ca000 - ffff880001800000)
[    1.612648] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1002.610934] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1053.523985] usb 2-2: New USB device found, idVendor=1059, idProduct=0017
[ 1090.249734] usb 2-2: New USB device found, idVendor=1059, idProduct=0017
[ 1762.296078] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1788.281211] usb 2-1: New USB device found, idVendor=1059, idProduct=0017
[ 1794.658211] usb 2-2: New USB device found, idVendor=1059, idProduct=0017
[ 7282.511744] usb 2-1: New USB device found, idVendor=1059, idProduct=0017

Thank you for any help!

Regards,
Gustavo Martinelli