Web lists-archives.com

Re: Debhelper compat levels




On 5/22/19 2:28 PM, Adam Borowski wrote:
> On Wed, May 22, 2019 at 02:06:03PM +0200, Simon Richter wrote:
>> I just did a very annoying backport. The reason it was annoying was that
>> two of the packages involved specified a debhelper compat level of 11.
>>
>> So in order to do the backport, I first had to get debhelper 11 (or 12).
>>
>> The debhelper 12 package itself has a compat level of 12, which means
> 
> echo "deb http://my-apt-box:3142/debian stretch-backports main" >>
> 	/srv/sbuild/stretch-amd64/etc/apt/sources.list

Alternatively, add this when starting sbuild:

--extra-repository='deb http://<whatever>/debian stretch-backports main'

Cheers,

Thomas Goirand (zigo)