Web lists-archives.com

Re: Debhelper compat levels

On Wed, May 22, 2019 at 02:06:03PM +0200, Simon Richter wrote:
> I just did a very annoying backport. The reason it was annoying was that
> two of the packages involved specified a debhelper compat level of 11.

We have debhelper 12 already available:

| debhelper  | 12.1.1~bpo9+1     | stretch-backports | source, all

> The debhelper 12 package itself has a compat level of 12, which means I
> couldn't compile it without the package itself being installed. Downgrading
> the compat level to 10 and relaxing the build dependencies seems to have
> worked, so I had a debhelper 12 package.

debhelper does not build-depend on itself, but is self-hosted:

| Package: debhelper
| Binary: debhelper, dh-systemd
| Version: 12.1.1
| Build-Depends: dpkg-dev (>= 1.18.0~), perl:any, po4a

> This package then depends on dh-autoreconf, which in turn requires
> debhelper 11 to build, so I had to again downgrade a compat level and build
> dependencies to build.

Also dh-autoreconf is already available:

| dh-autoreconf | 17~bpo9+1     | stretch-backports | source, all

Worse, it's in stable and oldstable as well and I did not find a single
package in Debian unstable requesting a version >> 14:

| dh-autoreconf | 10            | oldstable         | source, all
| dh-autoreconf | 14            | stable            | source, all

Please show what you are actually seeing.


... The prejudices people feel about each other disappear when they get
to know each other.
		-- Kirk, "Elaan of Troyius", stardate 4372.5