Web lists-archives.com

Re: fixing debian-security-support upgrades from stretch (for good)




On Mon, 2019-05-13 at 19:08 +0000, Holger Levsen wrote:
> reassign -1 base-files
> retitle -1 base-files: please add a break on d-s-s < 2019.04.25
> thanks
> 
> On Mon, May 13, 2019 at 01:00:14PM +0100, Ben Hutchings wrote:
> > On Mon, 2019-05-13 at 11:52 +0000, Holger Levsen wrote:
> > > So I think this can only be fixed properly (=without asking people to
> > > upgrade to the latest stretch pointrelease but instead allowing upgrades
> > > to buster from *any* stretch pointrelease) by adding a "pre-depends:
> > > debian-security-support (>= 2019.04.25)" to base-files in buster.
> > This makes debian-security-support transitively essential, whereas it
> > used to be optional.
> 
> thanks, Ben.
> 
> > Is "Conflicts" not strong enough?
>  
> after re-reading
> https://www.debian.org/doc/debian-policy/ch-relationships.html#packages-which-break-other-packages-breaks
> and
> https://www.debian.org/doc/debian-policy/ch-relationships.html#conflicting-binary-packages-conflicts
> (policy 7.3 and 7.4) I now also think that a "Breaks:
> debian-security-support (>= 2019.04.25)" in src:base-files is in order.

After re-reading, I concur that "Breaks" should be sufficient.  But
please do test this!

Ben.

-- 
Ben Hutchings
For every complex problem
there is a solution that is simple, neat, and wrong.


Attachment: signature.asc
Description: This is a digitally signed message part