Web lists-archives.com

Re: Introducting Debian Trends: historical graphs about Debian packaging practices, and "packages smells"




On Mon, Apr 15, 2019 at 04:55:12PM +0200, Andreas Tille wrote:
>     biococoa (U)         does not use Debhelper (no compat level found) (source version: 2.2.2-4)
>     biococoa (U)         should switch to dh. Current build system: cdbs (source version: 2.2.2-4)

| % grep cdbs -r biococoa-2.2.2 
| biococoa-2.2.2/debian/rules:include /usr/share/cdbs/1/rules/gnustep.mk
| biococoa-2.2.2/debian/rules:include /usr/share/cdbs/1/class/gnumakefile.mk
| biococoa-2.2.2/debian/control:Build-Depends: cdbs,
| biococoa-2.2.2/debian/changelog:     dh_installsystemd instead -> that's a cdbs issue)
| biococoa-2.2.2/debian/changelog:  * debian/control (Build-Depends): Add cdbs and quilt.  Drop gnustep-make

Regards,
Bastian

-- 
Military secrets are the most fleeting of all.
		-- Spock, "The Enterprise Incident", stardate 5027.4