Web lists-archives.com

Re: Golang >= 1.12 in Buster?




Hi,

On Sat, Apr 13, 2019 at 09:54:18PM +0800, Shengjing Zhu wrote:
> FWIW, golang-1.12 was removed from buster, because the RT think
> there're too many golang for buster[1].

there's no logic in that, and especially with the introduction of this
new feature, which the Go community has awaited for so long, I think
it's a perfect way to blast your legs off. It's a bit like removing
Python 3 because there were so many Python2 versions already. Or how
about removing Python2 altogether, then?

> [1] https://tracker.debian.org/news/1024215/golang-112-removed-from-testing/

Thank you for the pointer!

I strongly think that this decision very wrong and should be reversed.
If the RT absolutely insist on cutting down the number of Go versions, I
am not opposed to see eg. golang-1.11 go, however, as I don't see a
compelling case for having it. But others may disagree. In this way, I
fully agree with Eric on this matter.


Cheers,
Toni