Web lists-archives.com

Golang >= 1.12 in Buster?




Hello,

I just figured that Buster is, from the current POV, going to ship with
Golang 1.11. While I am new to Go, I figured that we should probably
have a newer version of Golang in Buster, as they are now doing
versioned dependencies, but only starting with 1.12 or 1.13 (not quite
sure about the difference here). This seems to be rapidly adopted by
projects out there, so having only older versions of Golang is becoming
useless quite soon. One project which I am trying to work on, coredns,
already does not compile with anything older than 1.12.

I know we are in freeze already, but I still need to ask, whether there
might be a freeze exception, or how we are going to remedy this
situation?


Cheers,
Toni