Web lists-archives.com

Re: nvidia-smi:i386/stretch-bpo




On 2019-03-26 19:57, Daniel Reichelt wrote:
> I'm wondering why there's no nvidia-smi:i386=410.104-1~bpo9+1 but only
> 390.87-8~bpo9+1.
> 
> Has the binary package just not been built yet for i386/stretch-bpo or
> is nvidia-smi no longer supported for i386 by upstream?

Driver support for 32-bit architectures has been discontinued by NVIDIA 
after the 390.xx series. For i386 most of the libraries are still provided
by the newer 410/418 series drivers. I.e. 32-bit (i386) binaries using
OpenGL etc. are fine as long as they are running under a 64-bit (amd64)
Xserver using the current drivers.
The 390 legacy driver with all packages (renamed to include -legacy-390xx
of course) on all previously supported platforms is still available as
src:nvidia-graphics-drivers-legacy-390xx.

So the package is still there:

nvidia-legacy-390xx-smi | 390.116-1~bpo9+1 | stretch-backports/non-free | amd64, i386
nvidia-legacy-390xx-smi | 390.116-1        | testing/non-free           | amd64, armhf, i386
nvidia-legacy-390xx-smi | 390.116-1        | unstable/non-free          | amd64, armhf, i386


Andreas

PS: today I uploaded src:nvidia-graphics-drivers with transitional
packages nvidia-driver, xserver-xorg-video-nvidia added on i386,armhf
that depend on the corresponding legacy driver packages.
I could do that for nvidia-smi as well. Any other (non-lib) packages?