Web lists-archives.com

Re: Accepted emacs 1:26.1+1-3.2 (source amd64 all) into unstable, unstable




Hi Andreas,

On Mon, Feb 04, 2019 at 01:00:13AM +0000, Andreas Beckmann wrote:
> Source: emacs
> Version: 1:26.1+1-3.2
> Closes: 916758
> Changes:
>  emacs (1:26.1+1-3.2) unstable; urgency=medium
>  .
>    * Non-maintainer upload.
>  .
>    * Add more transitional packages for ancient versioned packages
>      emacs21{,-nox}, emacs22{,-gtk,-nox}.  (Closes: #916758)

in #916758 you wrote:

--- begin ---
These were additional emacs variants available in lenny that may have
survived upgrading on a long-grown system.

I'm doing piuparts tests simulating such long grown systems locally and
would expect to find some ancient packages that break once a modern
emacs gets installed. So we would generate a list of Breaks against
cruft packages that would need to be added to the appropriate modern
emacs package.
--- end ---

in other words - and please correct me if I'm wrong - you added
long gone transitional packages back only to make some (more or less)
pointless upgrades from lenny behave better today?

I'm really not sure this is a sensible approach. Usually we try to get
rid off transitional packages, not to add new ones???!

lenny was released almost exactly 10 years ago. We should let it go.


-- 
tschüß,
	Holger

-------------------------------------------------------------------------------
               holger@(debian|reproducible-builds|layer-acht).org
       PGP fingerprint: B8BF 5413 7B09 D35C F026 FE9D 091A B856 069A AA1C

Attachment: signature.asc
Description: PGP signature