Web lists-archives.com

Failing autopkgtest for ruby-rails-assets-autosize and perfect-scrollbar




Hi,

I am trying to run autopkgtest for ruby-rails-assets-autosize and ruby-rails-assets-perfect-scrollbar on my system via the command:
autopkgtest -B ../ruby-rails-assets-autosize_4.0.2+dfsg-1_all.deb -- schroot unstable-amd64-sbuild

Now, it fails the test and the logs can be found at https://ghostbin.com/paste/3qbfn
In the end, it says:
Sprockets::FileNotFound: couldn't find file 'rails-ujs' with type 'application/_javascript_'

On taking a closer look, I found out that ruby-ujs in no longer maintained and the project has been archived. The README says that the project has been merged with rails 5.1.
But even then, the autopkgtest is failing. Even 'gem install rails-ujs' throws an error, which is obvious.
Although, meta/build seems to be working just fine (except for the autopkgtest).

What is the workaround here?
Should we possibly disable the tests for now?
Because this is a dependency of diaspora which we are trying to package and get it running at the earliest.


Best,
Utkarsh