Web lists-archives.com

Re: Remainings of old versions of packages in UDD / tracker




On Tue, Jan 22, 2019 at 08:48:15AM +0100, Andreas Tille wrote:
> This has settled for R packages now but I found another really strange one:
> 
> $ rmadison muparser | grep "unstable "
> muparser   | 2.2.3-6        | unstable           | source
> muparser   | 2.2.6.1+dfsg-1 | unstable           | source
> 
> According to buildd[1] muparser was build on all architectures.  There is
> a remaining version 2.2.3-6 and I have no idea why (neither why rmadison
> does not list binaries).

It does?
mattia@warren ~ % rmadison -S -s unstable muparser
libmuparser-dev | 2.2.6.1+dfsg-1 | unstable   | amd64, arm64, armel, armhf, hurd-i386, i386, kfreebsd-amd64, kfreebsd-i386, mips, mips64el, mipsel, ppc64el, s390x
libmuparser-doc | 2.2.3-6        | unstable   | all
libmuparser2v5  | 2.2.6.1+dfsg-1 | unstable   | amd64, arm64, armel, armhf, hurd-i386, i386, kfreebsd-amd64, kfreebsd-i386, mips, mips64el, mipsel, ppc64el, s390x
muparser        | 2.2.3-6        | unstable   | source
muparser        | 2.2.6.1+dfsg-1 | unstable   | source


You have a cruft libmuparser-doc (that interestingly is not listed in
the cruft-report…).


For the future, also what Lucas said may be relevant in some cases,
although luckily it's a rare matter and not many developers need to
mess with (or even know about) that.

-- 
regards,
                        Mattia Rizzolo

GPG Key: 66AE 2B4A FCCF 3F52 DA18  4D18 4B04 3FCD B944 4540      .''`.
more about me:  https://mapreri.org                             : :'  :
Launchpad user: https://launchpad.net/~mapreri                  `. `'`
Debian QA page: https://qa.debian.org/developer.php?login=mattia  `-

Attachment: signature.asc
Description: PGP signature