Web lists-archives.com

Re: Q: Debcheck warning "Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on $arch"




Quoting Paul Wise (2019-01-19 04:38:04)
> >  At
> >  https://qa.debian.org/debcheck.php?dist=unstable&package=fonts-sawarabi-mincho,
> >  it show as below but debhelper-compat (= 12) is satisfied in sid
> > > BuildDepends
> > >
> > > Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mips.
> ...
> >  How do I eliminate this?
> Needs someone to work on debcheck, to switch to libdpkug-perl for parsing
> (WIP patch in #816448) and then to implement Provides support (although I
> thought it already had that).

Alternatively, there is also this merge request to tracker that I just opened:

https://salsa.debian.org/qa/distro-tracker/merge_requests/55

It adds the results from

https://qa.debian.org/dose/debcheck/src_unstable_main/latest/some.html

to the tracker (release architectures only). The data is computed by dose3 and
should thus not suffer from the bug that you just encountered because dose3
understands versioned and unversioned Provides.

Thanks!

cheers, josch

Attachment: signature.asc
Description: signature