Web lists-archives.com

Re: autopkgtest coupled with sbuild different from what is run on buildd?




Hi Joseph,

On Wed, Jan 02, 2019 at 12:53:32PM -0800, Joseph Herlant wrote:
> Hi guys,
> 
> With one of my package (cmph), when I added debci tests, locally
> running autopkgtests using --run-autopkgtests in gbh that uses sbuild,
> I have no problem but when it runs on debci, it seems to miss packages
> (gcc at fist, now stdlibs, etc) or my local schroot has too many. I
> recreate my schroot but stil can't reproduce the issue locally.
> 
> So my question is:
> * Is it expected to have build-essential installed on the sbuild
> schroot but not on the deci one? (I'm guessing that's my problem but
> I'd like to know if that's a known issue)
> * do you know of any other dependencies differences that could occur
> between running autopkgtests through sbuild and the autopkgtest
> running on the debci servers?
> 
> My use case is that the package provides some short example programs
> on how to use the library and I'm compiling and running them to check
> that it runs fine.
> 
> Note: I apologize if that's already documented somewhere I didn't find.
> 
> Thanks for your help,
> Joseph
> 

Have you tried an LXC autopkgtest instance?  I've noticed that
sometimes packages whose tests pass 100% of the time with a schroot
(buildd profile) will fail on debci, and the only way I've been able
to reproduce the failure is with an LXC autopkgtest.

I will confess to not knowing why this is the case...but I've had
success with resolving failing tests in debci by debugging
LXC+autopkgtest failures.

Good luck, and I look forward to following this thread!
Happy New year,
Nicholas

Attachment: signature.asc
Description: PGP signature