Web lists-archives.com

perl versioned Provides in sid again




Hi,

just a note that I've re-introduced versioned Provides in
perl/perl-base/perl-modules-5.28 with 5.28.1-3.  This was briefly in
sid in July 2017 but had to be reverted [1] due to infrastructure issues
(#867104 / wanna-build and #867081 / autopkgtest) back then. The issues
have since been fixed, so I'm hoping everything will Just Work this time.

Please let us know (via debian-perl@ldo, perl@pdo or otherwise) should
any issues emerge.

No immediate action is required from packages affected by this change,
but they can now gradually start moving from the current idiom
 Depends: perl (>= x) | libfoo-bar-perl (>= y)
to just the 'libfoo-bar-perl (>= y)' part. This will need some changes
to lintian recommendations as well.

See #758100 for more information on the change.

[1] https://lists.debian.org/debian-devel/2017/07/msg00111.html

Happy hacking,
-- 
Niko Tyni   ntyni@xxxxxxxxxx