Web lists-archives.com

Re: call for epoch (was Re: Bug#915553: ITP: pd-csound -- Csound external for Pure Data)




On Tue, 04 Dec 2018 at 23:22:19 +0100, Adam Borowski wrote:
> On Tue, Dec 04, 2018 at 10:49:44PM +0100, IOhannes m zmölnig (Debian/GNU) wrote:
> > i asked upstream, and their answer is:
> > > The version was always 1.00 even when it was inside Csound. Minor
> > > changes made it go to 1.01 when we moved it out. It is not the same as
> > > the Csound version. So I am not really keen on changing this.
> > 
> > so it seems that the Debian *binary* package should have used a
> > different version than the source package in the first place.
> > 
> > it also gives me confidence, that the upstream version number will not
> > increment much in the next time, which should keep us safe from re-using
> > the same version (without epoch)

Based on what upstream said, I agree: go ahead with epoch 2. Thanks for
checking here and with upstream before uploading.

> There already is an epoch, you can't remove it.  On the other hand, with the
> damage already done, there's little reason not to bump it.

That's also a reasonable factor to take into account, and in this case
it leads to the same conclusion.

    smcv