Web lists-archives.com

Re: wxWidgets GTK+ 3 build available




Hello Scott,

Am 25.11.18 um 02:31 schrieb Scott Talbert:
> Hi,
> 
> Since ~March, we have a GTK+ 3 build of wxWidgets in Unstable/Testing. 
> Packages that use wxWidgets may switch over to this build if they desire, 
> although we are not pushing to remove the wx GTK+ 2 package in Buster, so 
> packages can continue to use the GTK+ 2 build for Buster.
> 
> To switch a package over to the GTK+ 3 build, it could be as simple as 
> changing the Build-Depends from libwxgtk3.0-dev to libwxgtk3.0-gtk3-dev, 
> rebuilding, and testing.

unfortunately I can't simply switch over to libwxgtk3.0-gtk3-dev for the
kicad package as some of the applications become mostly unusable if the
GTK+3 version of libwxgtk library is used. Upstream is working on this
problem but I fear were won't be a GTK+3 ready source of kicad before
the full freeze of Buster.

KiCad is partially also depending on wxpython3.0. But here there are
only GTK+3 linked binaries currently available and by this I need to
disable a useful scripting feature (used for AddOns) in KiCad since the
upload of 3.0.2.0+dfsg-7 [1].
For wxwidgets you are providing also "legacy" GTK+2 versions of the
libraries. Would this also be possible for wxpython3.0? Currently all
downstream distros are in the same position as me for the KiCad package.

[1]
https://tracker.debian.org/news/945651/accepted-wxpython30-3020dfsg-7-source-amd64-all-into-unstable-unstable/

-- 
Regards
Carsten Schoenert