Web lists-archives.com

PHP modules only for PHP 7.3 in buster




Hi,

I am deeply sorry if I'm on the wrong list. I am not a newcomer to
Debian, but I didn't take the time to dig in all the lists and processes.

Recently, I saw some PHP modules that hit testing and were only compiled
against PHP 7.3:

- php-apcu (#911719)

- php-igbinary (#911670)

- php-redis (#913357)

- php-mailparse

As the maintainer as said (in
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911670#10), it seems
that we are in the middle of a transition.

However, the main php package is still depending on php 7.2 : in the
meantime, a lot of module, and applications are completely broken.
Moreover, php7.0 and php7.2 are still available in buster, and it seems
that it's currently impossible to use those PHP versions with the above
modules. As far as I know, some applications are not able to run on PHP
7.3, so supporting PHP 7.2 in buster could be a good idea.

I also find cumbersome to launch "apt-mark hold php-<modulename>" for
now, waiting for an explanation or a resolution.

So my main question is: what is the plan for PHP modules?

Have a nice day,

Adrien