Web lists-archives.com

gbp import-orig has defeated me




Hi,

I would like to update the googletest salsa repo [1] with upstream 1.8.1.  So 
I downloaded the tarball and ran "gbp import-orig" on it.  That appeared to 
work, but "gbp buildpackage" fails with

  dpkg-source: error: aborting due to unexpected upstream changes ...

from the diffs, my guess is there is some line ending issue.  I've pushed 
everything to salsa repo.  Hoping someone here can take a look and point me in 
the right direction.

For good measure, I tried creating a brand new git repo to import the tarball, 

  git init
  gbp import-orig --pristine-tar ../googletest_1.8.1.orig.tar.gz
  ... copy debian dir from the salsa repo & commit ...
  gbp buildpackage

and ended up in the same situation!

Thanks,
-Steve

[1] https://salsa.debian.org/debian/googletest