Web lists-archives.com

Bug#909347: general: 9.5 GPU hardware acceleretion of my hardware is disable




Package: general
Severity: normal

Dear Maintainer,


    
I don't know which package causes this problem. The thing is ugrading Debian 9 disables
 my GPU hardware acceleration
    I did:  sudo apt update && sudo apt upgrade -y
    glxinfo -B after upgrade 
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 3.9, 128 bits) (0xffffffff)
    Version: 13.0.6
    Accelerated: no
    Video memory: 7176MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

lspci -knn | grep -i VGA -A3
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8570D] [1002:990e]
	Subsystem: ASUSTeK Computer Inc. Richland [Radeon HD 8570D] [1043:8526]
	Kernel driver in use: radeon
	Kernel modules: radeon
sudo dmesg | grep -E 'drm|radeon' | grep -iE 'firmware|microcode'
[sudo] пароль до koral: 
[    8.693169] [drm] Loading ARUBA Microcode
[    8.786378] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/ARUBA_pfp.bin
[    8.794635] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/ARUBA_me.bin
[    8.794891] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/ARUBA_rlc.bin
[    8.826982] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/TAHITI_uvd.bin
[    9.016678] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/TAHITI_vce.bin
[    9.018580] [drm] Found VCE firmware/feedback version 50.0.1 / 17!

   I expected that hardware acceleration mode work

-- System Information:
Debian Release: 9.5
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-8-amd64 (SMP w/4 CPU cores)
Locale: LANG=uk_UA.utf8, LC_CTYPE=uk_UA.utf8 (charmap=UTF-8), LANGUAGE=uk_UA.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)