Web lists-archives.com

Re: Package not compatible with old systemd




Hi,

st 19. 9. 2018 v 10:07 odesílatel Wouter Verhelst <wouter@xxxxxxxxxx> napsal:
> Conflicts is just more strict Breaks,

Eh, no.

ehm, yes: 7.4: Conflicts ... This is a stronger restriction than Breaks 

You're claiming that the systemd support of your package won't work
correctly unless you have a particular version of systemd on your
system. If that's the case, then you should Depend on the correct
version of systemd. If you also support other init systems, you can add
an alternate dependency on those other systems; or you can use
Recommends: rather than Depends: if you don't want it to be absolute.

but I want my package to work without init systems, for example inside Docker. But if systemd is installed, I need >= version.

--
Best regards
 Ondřej Nový
 
Email: novy@xxxxxxxxxx
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B