Web lists-archives.com

Re: Package not compatible with old systemd




Hi,

út 18. 9. 2018 v 12:18 odesílatel Michael Biebl <biebl@xxxxxxxxxx> napsal:
 assume you (re)start your service in postinst? In this case you need a
running systemd >= 235 at that point.

yes.
 
We do re-exec systemd in postinst, but a versioned Breaks or Conflicts
does not give you the guarantee that systemd.postinst has run before
your postinst.

this is not issue for me, because when I'm upgrading swift package, /var/cache/swift directory already exists from the past (created by older version of swift with "old" method).

Thanks.

--
Best regards
 Ondřej Nový
 
Email: novy@xxxxxxxxxx
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B