Web lists-archives.com

Bug#906249: general: Long pause after lightdm login, gimp not starting except under strace




Package: general
Severity: normal

Dear Maintainer,

after upgrading to debian testing, I ran into a few problems. First of all, as I am using fluxbox, and intend to continue, I could not use gdm any more - after login, the login screen would reappear after some time. Login to gnome was no problem. I installed lightdm and configured it to use X (instead of wayland). Right now, login is working, and the desktop appears, but only after a pause of up to several minutes which can be shortened by moving the mouse. Afterwards, everything seems to run normal, except: The gimp. On calling "gimp" form the command line, nothing happens. When using "strace gimp", the program starts; yet, opening jpg images is not possible (freeeze), the preview creation fails as well.
I do not know whether these bugs are related; somehow, as all of them are about starting programs, with strange measures to overcome at least the first obstacles (mouse movements, strace-call) I somehow suspect it.
Sincerely yours,

		Moritz

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (750, 'testing'), (50, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.17.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=C (charmap=ANSI_X3.4-1968), LANGUAGE=en_US.UTF-8 (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled