Web lists-archives.com

Re: Bug filing for autopkgtest regressions? [Was: Re: appears to break multiple autopkgtests]




That isn't a bug, either in python3.7 or in
the Python libraries.
Depends on your definition of "bug".

A package build-depending (or presumably test-depending) on python3-foo often expects to get "foo" for all supported python3 versions but the dependency structure only enforces that foo will be available for the default python3 version.

Afaict this deficiency is well-known but the possible fixes may well be worse than the current deficiancy.