Web lists-archives.com

Re: Status of wvstreams




On Tue, 05 Jun 2018 at 21:46:37 +0200, Sebastian Andrzej Siewior wrote:
> wvstreams has a RC bug due to the openssl transition. There seems not to
> be any upstream activity, the last commit on github was from 2011. It
> has one reverse dependency which is wvdial.
> wvdial itself saw its last upload in 2012. I can't reach upstream's
> homepage (alumnit.ca).

These seem likely to be dead upstream. Anyone maintaining these will
need to be prepared to be their de facto upstream developer.

> I was surprised to see that gnome-ppp depends on wvdial. The gnome-ppp
> package looks dead, too. Last upload moved the package to QA in 2017 and
> the upload before that was in 2012. The homepage link which is mentioned
> in #846802 does seem not to have anything to do with the package.

I'm not sure whether gnome-ppp was ever a GNOME project: it's from the
era of packages being named "gnome-whatever" because they are designed
to run under GNOME, rather than because they are part of GNOME. It
depends on libglade2, which has itself been obsolete for a long time
(see #895517). Again, I'm far from surprised if it's dead upstream.

> I never used wvdial myself[0] but
> I think NetworkManager should be able handle it.

NetworkManager supports PPPOE (e.g. ADSL), and cellular modems (3G, etc.)
via ModemManager. It doesn't support the analogue dial-up modems that
were popular 10-20 years ago. I don't think the major NM alternatives
(wicd, ConnMan etc.) support those either.

As with any no-longer-common hardware, support for this class of hardware
in Debian depends on someone doing the work. If someone cares enough
about dial-up modems to want to maintain wvdial and/or gnome-ppp in
Debian, then they should adopt wvstreams too.

Alternatives to wvdial include pppconfig (orphaned) or configuring
pppd by writing configuration files directly (hardly user-friendly,
but probably enough for retrocomputing enthusiasts).

    smcv