Web lists-archives.com

Re: Firefox 60esr on Stretch ?




W. Martin Borgert <debacle@xxxxxxxxxx> schrieb:
> On 2018-05-04 21:12, Moritz Mühlenhoff wrote:
>> Same as all previous extension breakages incurred by ESR transitions;
>> not at all. Apart from enigmail those are all not updated along
>> in stable, this doesn't scale at all. If you want your extensions
>> to be kept compatible, get them from the Mozilla addons page
>> like every other Firefox/Thunderbird user.
>
> This is not something I would consider.
> If a software is not in Debian, I just don't use it.

Your call. Don't use the extensions, then.

> Why? We have now a huge breakage for all XUL extensions, but
> were there problems of a similar scale before? Do we have to
> expect similar breakages in the future with the new API?

Sure, plenty of addons needed updates to remain compatible
with later Firefox (ESR) releases in the past. This model
is broken for many years already, totally independant of
the switch to web extensions.

Cheers,
        Moritz