Web lists-archives.com

Bug#897399: ITP: node-require-optional -- Node.js module to manage optional peer dependencies




Package: wnpp
Severity: wishlist
Owner: Xavier Guimard <x.guimard@xxxxxxx>

* Package name    : node-require-optional
  Version         : 1.0.1
  Upstream Author : Christian Kvalheim <http://christiankvalheim.com>
* URL             : https://github.com/christkv/require_optional
* License         : Apache-2.0
  Programming Lang: JavaScript
  Description     : Node.js module to manage optional peer dependencies

require_optional is a work around for the lack of optional peer dependencies
in Node.js.

Note that there is also another "require-optional" in npmjs.com. This one is
the most popular and the most downloaded. It is also a dependency of
official mongodb driver (node-mongodb-core, #897361).