Web lists-archives.com

Re: Please do not drop Python 2 modules




On Thu, 26 Apr 2018, Adrian Bunk wrote:
> We (Debian) have decided to support Python 2.7 in buster, like it or
> not.
>
> At that point it is not up to individual maintainers to sabotage
> Python 2.7 support in buster by dropping Python 2 packages without a
> valid technical reason.
> 
> "I want Python 2 to die" is not a valid technical reason here.

Some package maintainers do not wish to spend the time and effort
necessary to support python 2 indefinitely in their packages. That's a
reasonable personal assessment, and I applaud package maintainers for
saying so early, clearly, and publicly.

The question is what (if anything) do any of us want to do to provide
resources to provide that support.

We do not have unlimited maintainer time; triaging is sad, but it
produces better outcomes.

-- 
Don Armstrong                      https://www.donarmstrong.com

I shall require that [a scientific system's] logical form shall be
such that it can be singled out, by means of empirical tests, in a
negative sense: it must be possible for an empirical scientific system
to be refuted by experience.
 -- Sir Karl Popper _Logic of Scientific Discovery_ §6