Web lists-archives.com

Re: Removing Python 2 support in OpenStack [was: Please do not drop Python 2 modules]




On Thursday, April 26, 2018 10:40:49 AM Ondrej Novy wrote:
...
> we need Buster stable period for Py2->Py3 migration. We are going to be
> ready for Py3-only for Bullseye. Thousands of servers, millions lines of
> code.
...

I know very little about the details of OpenStack, but in case a somewhat 
parallel example is useful, that's approximately what Django will do.  
Bullseye will be Django 2.0, which is Python 3 only.  Buster is the pivot 
release where the third party elements of the Django ecosystem almost all 
support Python 3, so transition is possible to make ready for an all Python 3 
future. (AIUI anyway, I'm not a Django maintainer)

Scott K