Web lists-archives.com

Re: Bug#886968: btrfs-progs-udeb: depends on non-udeb: libzstd1




clone 886968 -1
retitle -1 debhelper: Make -V the default for dh_makeshlibs
severity -1 wishlist
tags -1 patch
thanks

Emilio Pozuelo Monfort:
> [...]
> 
> It's not in policy (but I don't think it has to be), but following the
> conversation on #-ftp yesterday I opened:
> 
> #895949 lintian: warn about packages with udebs but no udeb line in shlibs
> #895953 lintian: check that shlibs-version >= higher-version-symbols-file
> 
> The latter wouldn't enforce -V, but would check that we at least get a high
> enough version in shlibs as compared to the .symbols file (and would have solved
> the zstd problem).
> 
> Cheers,
> Emilio
> 

Related to this thread, I am wondering whether the default for
dh_makeshlibs should be changed in compat 12.  I have cloned #886968
(with this mail) and people with an interest are welcome to follow up on
that clone.

I have written a branch at [1] (review welcome).

Thanks,
~Niels

[1]:
https://salsa.debian.org/debian/debhelper/tree/dh-makeshlibs-c12-default-shlibs-versioning