Web lists-archives.com

Re: About the usage of Build-Depends in R packages (Was: Your upload of r-cran-xts)




On Fri, Mar 16, 2018 at 06:21:45AM -0500, Dirk Eddelbuettel wrote:
> 
> And I don't have time for this. Just one correction. You wrote:
> 
> | so had no real effect.  If you upload r-base-dev (>= 3.4.4) today
> | r-cran-xts remains build against r-base-dev (== 3.4.3) and will remain
> 
> and I don't know why you image the (== a.b.c) constraint. There is none.

You always build against the version that is currently inside Debian and
that version is determined at the point of upload (respective for a
given architecture when the build deamon starts building the package).
Unluckily I used the same syntax for a constraint in Build-Depends as I
was using for the fact I tried to describe better now.
 
Hope this clarifies the issue

     Andreas.

-- 
http://fam-tille.de