Web lists-archives.com

Re: (solved) Re: wireless fail after stretch installation




On Sun 04 Mar 2018 at 19:10:02 +0100, Philip Hands wrote:

> Jude DaShiell <jdashiel@xxxxxxxxx> writes:
> 
> > The least debian-boot membership could do would be to have a note come 
> > up for installers to execute a shell and do the file copy before 
> > rebooting once hard drive got mounted.  This is a problem for wifi users 
> > with no impact for ethernet users.
> 
> Your tone does not encourage a civil response, but you're going to get
> one anyway I'm afraid.
> 
> Since you didn't bother to say what you are complaining about in any
> useful way, I thought I'd look at the first post in the first thread
> referred to in the mail from Brian, which is about the fact that
> desktop-configured wifi connections don't come up until someone logs in.

You would have done better to have read further and, amongst other posts
which are pertinent to what Long Wind and Charlie S wrote, you would have
found this:

  https://lists.debian.org/debian-user/2018/02/msg00015.html

The plain and simple fact is that a user who installs over a wireless
link and does not have network-manager does not have any connectivity
to the internet after first boot. Long Wind solved the issue by taking
the advice given and Charlie S used his initiative and knowledge to
devise an /e/n/i file which replaced the one the installer had wiped
out.

This has been going on since Debian 7.0.0 and is not the first time the
issue has arisen here. Debian must be the only OS which deliberately
removes connectivity present during installation.

In the link above David Wright asks whether this is a "sick joke". If
the reasons for inflicting this issue on users were explained in some
detail, we could perhaps answer sensibly.

[Snip. The issue in this thread has nothing to do with an installed
network-manager.]

-- 
Brian.