Web lists-archives.com

Re: Can aolserver4 be considered superseded and removed?

On Tue, Feb 27, 2018 at 05:15:46PM +0100, Héctor Romojaro Gómez wrote:
I was meditating to replace Aolserver4 with Naviserver which is a
but has has a few incompatibilities in its Tcl API. On those regards 
Naviserver is in much better state.


Just in case this has been overlooked, there is already some effort
ongoing on the naviserver packaging. 

I filed an ITP[1] some time ago, and recently asked formally for a
first upload of the package and permissions over it (i am a DM)[2].
Volunteers to do it are of course welcome :)

Gulp! indeed I'm now remembering the ITP, but I missed the recent

As the openacs maintainer, which is also dependant on
aolserver4/naviserver, i would prefer to avoid maintaining different
configurations for both, so i am in favor of just replacing the
aolserver4 package with the new naviserver one, taking into account
possible transition issues.

I would suggest to provide a migration package for AOLserver users
with a NEWS document about possible issues due to known problems.
I'll have a look to the current package. Let's move this thread on
te pkg-tcltk-devel list.

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804043
[2] http://lists.alioth.debian.org/pipermail/pkg-tcltk-devel/2018-February/003546.html

Kind regards,

Francesco P. Lovergine