Web lists-archives.com

Bug#891502: ITP: irda-dkms -- IrDA subsystem and device drivers




Package: wnpp
Severity: wishlist
Owner: Christopher Schramm <debian@xxxxxxxxxxx>

* Package name    : irda-dkms
  Version         : 0.1
* URL             : https://github.com/cschramm/irda
* License         : GPL
  Programming Lang: C
  Description     : IrDA subsystem and device drivers

The IrDA subsystem and device drivers got moved to staging and scheduled for
removal upstream in Linux 4.14 [1] and consequently disabled in the Debian
builds [2].

[1] https://lkml.org/lkml/2017/8/27/126
[2] https://anonscm.debian.org/cgit/kernel/linux.git/commit/?id=d12b3a11b2800489cde0be2d74872af04b5b8f36

As I personally do have a use case for IrDA and am sure that I am not the only
one, I moved the code (from 4.15; not compatible to 4.14!) into a GitHub
repository [3], converted the build system to Kbuild files, and added a DKMS
configuration and a Travis CI configuration to check the build with current
kernel releases.

[3] https://github.com/cschramm/irda

I already prepared the packaging files. See [4] for copyright and license.

[4] https://github.com/cschramm/irda/blob/debian/debian/copyright