Web lists-archives.com

Fading out Tcl/Tk 8.5 from Debian




Hi fellow developers,

Since Tcl/Tk 8.5 is currently at its End of Life (see [1]) I would
like to start a campaign on removing it from Debian.

There's a wiki page [2] with all binary packages which depend on
Tcl/Tk 8.5 directly or indirectly, and with all packages which
build-depend on tcl8.5-dev or tk8.5-dev. (Not all of them need
patching, it's still a rough list)

I'm planning to start filing bugs with suggestions on how to switch to
Tcl/Tk 8.6 or may be to the currently default Tcl/Tk (which is now
8.6, but 8.7 is coming soon with fewer incompatibilities with respect
to 8.6 than for 8.6 against 8.5).

As for now the bugs severity will be 'important', but I plan to bump
it to 'serious' before the buster's release.

If there are comments or suggestions on what should I do before
starting filing the bugs, please tell.

[1] https://core.tcl.tk/tcl/wiki?name=Index
[2] https://wiki.debian.org/Teams/DebianTclTk/TclTk85Removal

Cheers!
-- 
Sergei Golovan