Web lists-archives.com

Bug#883133: Bug#883134: general: Add new package header Upstream-Version:




On Thu, 2017-11-30 at 12:15 +0100, Geert Stappers wrote:
Control: tags -1 moreinfo On Thu, Nov 30, 2017 at 04:25:54AM +0200, Victor Porton wrote:
I am writing software which should call a program in specific version range (or fail to call it if the program in this version range is not installed).
Please elaborate the problem you want to solve.
I am writing software for transforming between XML namespaces. The transforming is done by "scripts" (Python scripts, XSLT scripts, Ruby scripts, Bash scripts, etc.) For each conversion I specify several alternative scripts. A script may be specified by a user of my software by the URL of the script and name and version range of the interpreter (simplified explanation). For example, in input of my software there may be the following alternative converters: Python 2.7.1 - 2.7.14 http://example.org/script.py XSLT 1.0 - 1.1 http://example.org/script.xslt To choose an installed interpreter, then my program should check if "python2.7" is installed, if its version is in 2.7.1 - 2.7.14 range. It also to check if "xsltproc" is installed and its version. For this I need the upstream versions of "python2.7" and "xsltproc".